Tuesday, November 15, 2016

minor firmware update 0.963 for CT5 revision k and l


Summary:
This minor update fixes a bug in mode 1. No new features are added.

Relevant links:
Firmware release 0.963 for rev k,l 
Installation Instructions

Detail:
Bug fix Mode 1:
Turning on modulation in Mode 1 via the LEN B knob (Q switch down, turn LEN B) introduced some artifacts in the audio depending on it's resting position. This has been fixed. This bug was not present in 0.96 but was introduced in version 0.962

To enable modulation hold down the Q switch in Mode 1. Turning FBK will control the depth of the modulation (cCW = no depth, CW = Max Depth). Turning LEN B controls the speed (CCW = slowest speed, CW = fastest speed). On power up both speed and depth are set to their minimum values.

Special thanks to TM for reporting this issue.


9 comments:

Alessandro Rossi said...

Hi Scott,
Maybe this has already been answered before, but... will the firmware upgrade work also when performed with a Windows 10 pc?
I ask because the compatibility specs of the necessary software go up to Win 7 or 8 if I am not mistaken. My laptop has Win 10 installed, however. Will this cause known issues?
Thanks, cheers
Alessandro

Damon said...

Hi Scott,

Is there any plan to bring the filter feature for mode 1 to the rev L pedals? It doesn't seem to work on mine. Thanks!

Scott said...

@Alessandro

I don;t have windows 10 to test with but maybe you can check and let us know? Another avenue is dfu-util but dfuse is cleaner.

@Damon

It is already on Rev L. Push the Q switch down and turn DIR 1.

let me know

S

Damon said...

@Scott - Thanks so much, that worked! I was mistakenly holding down the soft footswitch instead of Q. Cheers, and can't wait for the next round of the 856!

Scott said...

@ Damon,

Yes sorry the main manual is out of date but there is a nice description of the controls in the .96 update post from N. Gill.

I will try to update the main manual page this week.

https://drive.google.com/file/d/0BwlfmEoxsd0GS1dRbEQxS1pHNUU/view?usp=sharing
http://mtlasm.blogspot.ca/2016/07/new-firmware-096-for-rev-k-l-boards.html

S

Scott said...

@Alessandro

At least one user reporting windows 10 is fine. PLease let us know if you have any issues.

Alessandro Rossi said...

Hi Scott,

My Windows 10 laptop was in the need for assistance these days, and I ended up using my Win7 desktop pc for the CT5 update instead. So I won' t be able to tell you about any Win10-related issues... but i am happy to report that the 0.963 firmware upgrade for my CT5 rev k was successful and I encountered no problems at all. I checked all the new features for mode 1 (low pass filter holding down q+dir1, muting write head holding down soft switch) and they all work. And no artifacts are introduced when I change the lfo frequency.

I' m really happy with this new firmware update, keep up the good work!

Cheers,

Alessandro

Scott said...

@Alessandro

Ok great. Also many people now reported no issue with win 10 so it should be fine for you in the future.

S

Edwin Burnett said...

Hi Scott,

Any idea when the Save Preset functionality will reveal itself in an update?

Hope all is well!